VSC Light

  #1  
Old 07-22-2007, 01:19 PM
Thread Starter
Join Date: Jul 2007
Posts: 3
Default VSC Light

My car is a 1999, LS400 with 167,000 miles. I had the front rotors replaced three weeks ago. Since that time there has been a noise similar to a bearing going bad, but only happens when the breaks are applied. I guessed it was just the old pads working into the new rotors.

Two days ago the car died while comming to a stop. The car restarted but the Check VSC light was on. I drove for two hours and had no problem. When I stopped for fuel and restarted the car the light whent off.

Today while sitting in a drive through line I noticed the radio shutting off when I pressed the break pedal. It did this four to five times and then the car shut off. When I restarted the car the VSC light was back on.

I am going to pull the tires and inspect the front breaks to see if there is anything out of the ordinary, any ideas???
 
  #2  
Old 07-23-2007, 11:39 AM
Join Date: Jul 2007
Location:
Posts: 34
Default RE: VSC Light

you might have an electrical problem.... if you can go to autozone they can run free diagnostics for you and tell you whats wrong with your car....
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
halexus
Lexus ES
0
04-28-2013 07:07 PM
rx300 girl
Lexus RX
3
09-20-2012 10:21 PM
joycewal
Lexus Forum Help & Suggestion Center
1
06-15-2010 08:40 PM
bevans
General Tech Help
0
06-14-2006 02:41 AM
m3amg43
Lexus GS
2
12-22-2005 02:46 PM


Thread Tools
Search this Thread
Quick Reply: VSC Light


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.