Have to press accelerator to start my '99 ES 300

  #1  
Old 10-09-2007, 02:42 PM
Thread Starter
Join Date: Oct 2007
Posts: 2
Default Have to press accelerator to start my '99 ES 300

When I start my '99 ES 300, sometimes I have to push the accelerator and then turn the key to get it to start. Does anyone know what is wrong and how to fix it? There is no check engine light on. Thanks.
 
  #2  
Old 10-12-2007, 06:37 AM
Join Date: Oct 2007
Posts: 7
Default RE: Have to press accelerator to start my '99 ES 300

Your idle air control motor, or IAC, is stopped up with carbon. Cleaning or replacement is in your future. Both work just as well.
 
  #3  
Old 10-12-2007, 08:10 AM
Thread Starter
Join Date: Oct 2007
Posts: 2
Default RE: Have to press accelerator to start my '99 ES 300

Thank you very much. I will get that checked out.
David
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bmaxey
Lexus GS
1
03-05-2019 07:05 AM
lowcost526
Off Topic
0
05-29-2011 10:05 PM
WaryViatret
General Tech Help
8
03-02-2010 07:24 PM
WaryViatret
Off Topic
7
03-02-2010 04:51 PM
ir269563
New Member Area
0
01-27-2009 12:41 AM


Thread Tools
Search this Thread
Quick Reply: Have to press accelerator to start my '99 ES 300


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.