pinging noise

  #1  
Old 07-29-2011, 03:07 AM
Junior Member
Thread Starter
Join Date: Jul 2011
Posts: 8
Default pinging noise

took my rx300 2000 to the dealer and they checked it out and no codes they did a little adjustment for the timing but still pings/rattles.. up hill loads at any speed.. then I took it to the auto part store to have them do the code readings and still PASS no codes.. the Lexus has around 109k miles on it... ok now we just bought the car like 4 months ago.. and we have been putting regular unleaded in it for about 2-3 tanks worth.. then we found out it takes premium so we been using Chevron premium and still pings. other than that car runs great.. The dealer dont know what to say. auto part store said try replacing the feul filter,,, HELP!
 
  #2  
Old 08-07-2011, 12:26 PM
Junior Member
Join Date: Aug 2011
Posts: 2
Default Pings "free fuel injector from carbon deposits"

A full tank of gas and 18 FL. OZ of MARVEL MYSTERY OIL in your fuel tank twice in a row right before you'll make a long distance trip ( 30-ml )will take care of the pings like it did for my 2000 RX300.
 

Last edited by jhsepah; 08-07-2011 at 12:32 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jrpauk
Lexus GS
3
04-12-2008 08:42 PM
tcdaveiga
Lexus GS
0
09-05-2006 02:44 PM
blau69
Lexus ES
0
08-09-2006 09:25 PM
JTomo
General Tech Help
1
02-03-2006 03:30 PM
Kerminator
Lexus ES
2
11-14-2005 11:19 PM


Thread Tools
Search this Thread
Quick Reply: pinging noise


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.