05 RX330 Panel Button corruption

  #1  
Old 07-12-2011, 09:03 AM
Junior Member
Thread Starter
Join Date: Jul 2011
Posts: 2
Default 05 RX330 Panel Button corruption

A few days ago after starting my 05' RX330 I noticed that the Nav screen was blank. No "I accept" screen, nothing. Pressing a few of the A/C buttons I found that some did nothing at all, and some functioned, although their functions were very different than they should be. No Menus, no trip info, no climate control screens, just stereo control / station info screens that I never used to have at all.

It seemed as though that only the stereo was linked to the display now, which it never used to be. Then, pressing the "A/C off" button brought back the GPS map.

Then, after pressing the Climate Control button, my wife's side went to full cold A/C, and mine to full high heat with no apparent way to change it.

Panel buttons are still wrong after pulling the battery cable in an attempt to clear memory. I had to reprogram the windows and sunroof, but no change to the panel button function corruption.

I was able to determine that the passenger side temp up button now controls the master temp down. It appears as though some software or firmware corruption has occurred within whatever module controls those functions.

Anyone with any similar symptoms or suggestions? I can't find anything similar searching the web and kind of need to know where to start with this problem, and have no dealer nearby...
 
  #2  
Old 07-13-2011, 04:01 PM
Junior Member
Thread Starter
Join Date: Jul 2011
Posts: 2
Default

Update:

While searching the forums I found the procedure for accessing the diagnostic nav menu which unbelievably has a test process for the panel buttons. Each one now has been assigned a different function than what it should be, and many of my old functions are not assigned to any button, but there doesn't appear to be any way to change them back.

So I found out that they're all wrong, now what?!?! Lexus must have had a pretty good reason to create a test that does nothing but confirm these button functions, i.e. I can't possibly be the first person on the planet to have experienced this problem.

I've also located a Lexus factory service manual which outlines the above test, and is complete with diagnostic flow charts, which documents absolutely nothing about what to do if the button assignments are incorrect.

I'm 2 1/2 hours away from the nearest dealer that I'd trust to charge me $200.00 for a diagnostic scan that will tell me what I already know.

Question is, what needs to be done to fix this problem, a reprogramming, or a replacement of whatever module must be suffering from early onset dementia?
 
  #3  
Old 07-19-2011, 05:21 AM
Junior Member
Join Date: Jul 2011
Posts: 7
Default

Originally Posted by Reposado View Post
Update:

While searching the forums I found the procedure for accessing the diagnostic nav menu which unbelievably has a test process for the panel buttons. Each one now has been assigned a different function than what it should be, and many of my old functions are not assigned to any button, but there doesn't appear to be any way to change them back.

So I found out that they're all wrong, now what?!?! Lexus must have had a pretty good reason to create a test that does nothing but confirm these button functions, i.e. I can't possibly be the first person on the planet to have experienced this problem.

I've also located a Lexus factory service manual which outlines the above test, and is complete with diagnostic flow charts, which documents absolutely nothing about what to do if the button assignments are incorrect.

I'm 2 1/2 hours away from the nearest dealer that I'd trust to charge me $200.00 for a diagnostic scan that will tell me what I already know.

Question is, what needs to be done to fix this problem, a reprogramming, or a replacement of whatever module must be suffering from early onset dementia?
I think you need to reprogram it instead replacing the module
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
harveyman84
Off Topic
1
01-11-2012 12:05 PM
edfmurphy
Lexus RX
2
12-11-2008 05:40 PM
nghiaho58
Lexus RX
2
03-07-2008 10:47 PM
jerry_es300
General Tech Help
0
01-31-2008 12:55 AM
kellinltd
New Member Area
0
05-07-2007 03:35 AM


Thread Tools
Search this Thread
Quick Reply: 05 RX330 Panel Button corruption


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.