470 radio/amplifier failure

  #1  
Old 02-04-2008, 05:10 PM
Thread Starter
Join Date: Feb 2008
Posts: 1
Default 470 radio/amplifier failure

2001 Lexus LX-470
One speaker in back, forget which side, starting making scratching/popping noises.
Using Fade/side controls at radio, ignored the problem hoping I could sometime open the panel and check the speaker.
Then, radio/dvd all went out with no sound whatsoever
Then, very, very loud static/popping/cracking sound from speaker system mostly at startup for about 3 minutes but then randomly later when driven.
Took to dealer, said amplifier was probably the issue.
$850 for new amp and then they could further analyze.
Getting varying/suspect quotes from aftermarket installers that require new amp, new wiring, and even new radio/dvd.
Any and all ideas appreciated..
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
timbowman1
Lexus ES
0
12-13-2009 11:33 PM
LEXUSBUYER
Lexus LX
2
11-27-2007 09:43 PM
LEXUSBUYER
Private 'Wanted' Classifieds
1
07-20-2007 07:56 PM
thrustdoctor
Lexus LS
1
01-03-2006 02:51 PM
alaqua
Lexus LX
0
12-15-2005 09:25 PM


Thread Tools
Search this Thread
Quick Reply: 470 radio/amplifier failure


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.