Go Back  Lexus Forum - Lexus Enthusiast Forums > Lexus Models > Lexus LS
Reload this Page >

1992 Lexus Turn Signals and hazards not working help please

1992 Lexus Turn Signals and hazards not working help please

  #1  
Old 08-14-2008, 08:35 PM
Thread Starter
Join Date: Aug 2008
Posts: 1
Default 1992 Lexus Turn Signals and hazards not working help please

Hey guys I am new here and I just got a gift from my uncle. I got a 1992 Lexus LS 400

But I have a problem

for some reason the turn signals do not turn on and the hazards do not work when you press the hazard button.

It will work when it feels like it.

I don't think it is the fuse because it turned on just once, so it's not the lights either because the dash doesn't indicate that the hazard or the turn signal is on because it doesn't show up on the dash either.

So I don't know where to start looking, i think it might be a bad relay switch or the wires are bad but I'm not so sure.

Can anyone help me with this. I am sure that it is an easy fix.
thanks
 
  #2  
Old 08-20-2008, 02:49 AM
Join Date: Mar 2007
Posts: 24
Default RE: 1992 Lexus Turn Signals and hazards not working help please

do check you relays... it might be that causingyou the problem
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
P A U L
Lexus ES
0
07-30-2008 10:11 PM
huggieb3
Lexus LS
1
08-13-2007 07:24 PM
gage
General Tech Help
1
07-21-2007 01:39 PM
MY1LS400
Lexus LS
0
01-07-2007 03:43 AM
98gs400
General Tech Help
0
01-12-2006 03:51 PM


Thread Tools
Search this Thread
Quick Reply: 1992 Lexus Turn Signals and hazards not working help please


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.